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1. Introduction 
 
 
ARTS PDF Workshop is an add-in for Microsoft® Excel that allows users to easily manage their PDF 
document collection.  ARTS PDF Workshop creates an Excel spreadsheet that is populated using file 
information from these PDFs.  The spreadsheet can be updated with any required changes and 
these changes, once applied will be reflected in the original PDF files.  ARTS PDF Workshop offers 
an effective and easy to use way to update and manage important document information and 
control security.  
 
Some of the features available included in ARTS PDF Workshop are:  
 

• Merge multiple PDFs. 
• Copy one/multiple PDFs. 
• Open one/multiple PDFs. 
• Review multiple PDFs Document Metadata. 
• Update multiple PDFs Document Metadata (spreadsheet to PDFs). 
• Print multiple PDFs. 
• Apply security on PDFs. 
• Set initial view in PDFs. 
• Refresh Worksheet. 

 

 
 

Figure 1. The ARTS PDF Workshop toolbar inside MS Excel 
 

 
| CONTENTS |    Page 3 of 19   
   



  ARTS PDF Workshop User Guide 
  Introduction 
 

 

 
 

Figure 2. The ‘Run ARTS PDF Workshop’ main dialog 
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2. Setup 
 
 

2.1. System Requirements 
 

Windows 
 

• Intel® Pentium® processor or equivalent 
• Microsoft® Windows 98 SE, ME, Microsoft Windows NT® Workstation 4.0 with 

Service Pack 6, Windows® 2000 with Service Pack 2, Windows XP Professional or 
Home Edition, or Windows XP Tablet PC Edition 

• Microsoft® Excel 97, 2000, XP, 2003 
• 64MB of RAM (128MB recommended) 
• 50MB of available hard-disk space 
• 1,024x768 screen resolution 

 
For technical support queries, please consult the Troubleshooting section of this manual or email 
techsupport@artspdf.com. 

 
 

2.2. Installation 
 

You may have received this software on either CD-ROM or as a downloaded file.  
 

Windows (CD-ROM) 
 

To install from a CD-ROM: 
1. Verify that Adobe Acrobat is not running. 
2. Insert the CD-ROM. 
3. If the CD-ROM does not automatically start, navigate to the CD in Windows 

Explorer and execute the Windows Installer.exe file. 
4. Navigate to ARTS PDF Workshop. 
5. Click Install. 
6. Follow the prompts to install ARTS PDF Workshop.  

 
Windows (.exe) 

 
If you downloaded ARTS PDF Workshop, to install: 

1.  Verify that Adobe Acrobat is not running. 
2.  Execute the installation file provided. 
3.  Follow the prompts to install ARTS PDF Workshop.  
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2.3. Activation 
 

If you have the demo version of ARTS PDF Workshop installed, activate the full version 
using the following steps:  

1. Select ‘Run ARTS PDF Workshop’ the Data menu within Excel or click the ‘Run 
ARTS PDF Workshop’ toolbutton. 

2. Select the ‘About’ button. 
3. Ensure you have a valid serial.  To obtain a valid serial you must purchase the 

product: 
a. Select the ‘Register’ tab page and click on ‘Buy Now’ to purchase the full 

version. 
b. After your purchase has been confirmed, you will receive an email containing 

your serial number. 
4. Select the ‘Register’ tab page and click on ‘Activate’. 
5. Enter your license details, including your serial number, and click “OK”. 

 
 

2.4. Uninstall 
 

Windows 
 

To install on a Windows platform: 
1. Verify that MS Excel is not running. 
2. Click Start > Settings > Control Panel. 
3. Open Add/Remove Programs. 
4. Select ‘ARTS PDF Workshop 3.0’ from the menu. 
5. Click ‘Add/Remove’.  
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3. Using ARTS PDF Workshop 
 
 

3.1. Getting Started 
 
After successfully installing ARTS PDF Workshop, open MS Excel and locate the ARTS 
PDF Workshop Toolbar (described below).  If the toolbar is not present please consult 
the FAQ section of this user guide. 
 
Before being able to apply any updates to your PDF document collection you must first 
populate a spreadsheet with document information. To do this you must first Run ARTS 
PDF Workshop (see section 3.13).  After the spreadsheet has been created by ARTS 
PDF Workshop it is then possible to execute any of the required functions on files within 
the selected rows. 

 
 

3.2. ARTS PDF Workshop Toolbar 
 

The Toolbar controls the functionality of ARTS PDF Workshop. 
 

 
 

Figure 3. ARTS PDF Workshop Toolbar 
 
Additional information 
 
Alternatively, you can always right-click on the spreadsheet, which will provide you with 
a menu allowing you to perform all the functions the menu does.  The available features 
are: 
 

• Merge Files 
• Remove Logs 
• Copy Files 
• Open PDF files 
• View Metadata 
• Update Metadata 
• Print File 
• Apply Security 
• Refresh Worksheet 
• Set Initial View 
• Run ARTS PDF Workshop 
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3.3. Remove Logs 
 
Removes all ARTS PDF Workshop logs from the current spreadsheet. 
 

 
 

Figure 4. ‘Remove Logs 
 
Instructions on use 
 

1. Select any entry in a valid ARTS PDF Workshop spreadsheet. 
2. Press the ‘Remove Logs’ button (Figure 4). 

 
Additional information 
 
It is important to note that you cannot remove a single ARTS PDF Workshop log.  Using 
this function will remove all logs simultaneously. Clicking on ‘Remove Logs’ clears all the 
logs in the spreadsheet. 
 
 

 
 
 
Each log appears as a little red mark in the corner of the cell.  Pointing your mouse 
cursor over cell makes the log appear.  Above is an example of a log file. 

 
 

3.4. Merge Selected PDFs 
 
Merges multiple PDFs into one, and then saves the new PDF to the specified location. 
 

           
 

Figure 5. Merge Files 
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Instructions on use 
 

1. Select two or more PDFs to merge together from the spreadsheet. 
2. Click on the ‘Merge Files’ button (Figure 5). 
3. Select the destination for the new PDF file. 
4. Choose the name for the new PDF file. 

 
Additional information 
 
This function is limited to use with PDFs containing no security of any kind (passwords 
and ‘Do Not Allow’ options).  If the merging process is initiated on PDFs containing 
security, they will be highlighted, and the process aborted. 
 
 

3.5. Copy Selected PDFs 
 
Copies multiple PDFs to a specified location. 
 

 
 

Figure 6. Copy Files 
 
Instructions on use 
 

1. Select the PDFs you wish to copy from the spreadsheet. 
2. Press the ‘Copy selected PDFs’ button (Figure 6). 
3. Select the destination for the copied files. 

 
 

3.6. Apply Security on Selected PDFs 
 
Configures multiple PDFs security – open and security passwords, as well as ‘Do Not 
Allow’ options. 
 

 
 

Figure 7. Apply Security 
 
Instructions on use 
 
Adding security settings to PDFs containing no security: 
 

1. Enter the new open and / or security passwords into the ‘User Password Present’ 
and / or ‘Master Password Present’ columns consecutively, for the PDFs you wish 
to secure. 

2. Configure any ‘Do Not Allow’ options that you require.  The options that you can 
change are: Printing, Changing, Selecting & Adding. 
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3. Select the PDFs whose security settings you wish to configure. 
4. Press the ‘Apply security’ button (Figure 7). 
5. Press the ‘Update Metadata’ to apply the security settings. 

 
Changing the security settings of PDFs already containing security: 
 

1. Enter the current open and / or security passwords into the ‘Current User 
Password’ and / or ‘Current Master Password’ columns, followed by the new 
passwords into the ‘New User Password’ and / or ‘New Master Password’ columns 
for the PDFs whose security settings you wish to modify (if removing the 
password, leave the ‘New User Password’ and / or ‘New Master Password’ 
columns blank). 

2. Configure any ‘Do Not Allow’ options that you require 
3. Select the PDFs whose security settings you wish to configure. 
4. Press the ‘Apply Security’ button (Figure 7). 
5. To apply the newly added feature, press ‘Update Metadata’ 

 
Additional information 
 
The ‘Printing’, ‘Changing the Document’, ‘Selecting Text and Graphics’ and ‘Adding or 
Changing Annotations and Form Fields’ columns return ‘Y’ if the option is disabled, ‘N’ if 
it is not, and ‘?’ if it cannot be determined.  When modifying the ‘Do Not Allow’ options, 
entering ‘Y’ will disable the feature and ‘N’ enables it (e.g. entering ‘Y’ into the ‘Printing’ 
column for a PDF will disable printing).  The entry is not case sensitive (e.g. ‘Y’ or ‘y’, ‘N’ 
or ‘n’ will still work). 
 
No security settings can be modified when a PDF contains a security password, unless 
the security password is supplied (in the ‘Current Security Password’ column).  In the 
event of trying to modify the ‘Do Not Allow’ options for a document with an open 
password, but no security password, the open password must be supplied (in the 
‘Current User/Master Password’ columns). 
 
 

3.7. Open Selected PDFs 
 

Opens multiple PDFs in Acrobat. 
 

 
 

Figure 8. Open Files 
 
Instructions on use 
 
Opening non-secured PDF file: 
 

1. Select the PDFs you wish to open. 
2. Press the ‘Open Files’ button (Figure 8). 
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Opening a secured PDF file: 
 

1. Enter the open password into the ‘Current User/Master Password’ columns for the 
corresponding PDFs that you wish to open. 

2. Select the relevant PDFs. 
3. Press the ‘Open Files’ button (Figure 8). 

 
 

3.8. Set Initial View on Selected PDFs 
 
Configures the way the PDFs appear when they are opened in Acrobat. 
 

 
 

Figure 9. Set Initial View 
 
Instructions on use 
 
Configuring Open Info for non-secured PDFs: 
 

1. Select the PDFs whose Open Info you wish to configure. 
2. Select one of the three appearance options  
3. (Note: selecting none will reset the Open Info to default – Page Only). 
4. Press the ‘Set Initial View’ button (Figure 9). 

 
Configuring Open Info for open secured PDFs: 
 

1. Enter the open password into the ‘Current User/Master Password’ columns for the 
corresponding PDFs whose Open Info you wish to configure. 

2. Select the relevant PDFs. 
3. Select one of the three appearance options 
4. (Note: selecting none will reset the Open Info to default – Page Only). 
5. Press the ‘Set Initial View’ button (Figure 9). 

 
Additional Information 
 
There are three options available that can be set for the initial view. These are case 
sensitive and should be written with the first letter as capital.  Available options are: 
 

 Bookmarks 
 Page 
 Thumbnails 
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3.9. Review Document Info for Selected PDFs 
 
Open multiple PDFs in Acrobat, and display their General Info window. 
 

 
Figure 10. Display Metadata 

 
Instructions on use 
 
Reviewing Document Info for non-secured PDFs: 
 

1. Select the PDFs whose Document Info you wish to review. 
2. Click the ‘Display Metadata’ button (Figure 10). 

 
Reviewing Document Info for open secured PDFs: 
 

1. Enter the open password into the ‘Current User/Master Password’ columns for the 
corresponding PDFs whose Document Info you wish to review. 

2. Select the relevant PDFs. 
3. Click the ‘Display Metadata’ button (Figure 10). 

 
 

3.10. Update Metadata on Selected PDFs 
 
Updates the Document Info for multiple PDFs, with that of the ‘Title’, ‘Subject’, ‘Author’, 
‘Keywords’, ‘Creator’ and ‘Producer’ columns on the spreadsheet. 
 

 
 

Figure 11. Update Metadata 
 
Instructions on use 
 

1. Modify the information within the ‘Title’, ‘Subject’, ‘Author’, ‘Keywords’, ‘Creator’ 
and ‘Producer’ columns as required. 

2. Select the PDFs that you wish to update. 
3. Press the ‘Update Metadata’ button (Figure 11). 
4. Press ‘Yes’ when prompted. 

 
Additional information 
 
This function is limited to use with PDFs containing no security of any kind (passwords 
and ‘Do Not Allow’ options). 
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3.11. Refresh Spreadsheet Information 
 
Updates the information contained within the spreadsheet, with that contained in the 
PDFs.  Especially useful when PDFs on a spreadsheet have been modified outside of PDF 
Workshop, or after PDFs security settings have been modified within PDF Workshop. 
 

 
 

Figure 12. Refresh Worksheet 
 
Instructions on use 
 
Refreshing PDFs containing no open passwords: 
 

1. Select the PDFs whose spreadsheet information you would like to refresh. 
2. Press the ‘Refresh Worksheet’ button (Figure 12). 

 
Refreshing PDFs containing open passwords: 
 

1. Enter the open password into the ‘Current User/Master Password’ columns for the 
corresponding PDFs whose spreadsheet info you wish to refresh. 

2. Select the relevant PDFs. 
3. Press the ‘Refresh Worksheet’ button (Figure 12). 

 
 

3.12. Print Selected PDFs 
 
Prints multiple PDFs to the default printer. 
 

 
 

Figure 13. Print Files 
 
Instructions on use 
 
Printing non-secured PDFs: 
 

1. Select the PDFs that you wish to print. 
2. Press the ‘Print Files’ button (Figure 13). 

 
Printing open secured PDFs: 
 

1. Enter the open password into the ‘Current User/Master Password’ column for the 
corresponding PDFs that you wish to print. 

2. Select the relevant PDFs. 
3. Press the ‘Print Files’ button (Figure 13). 
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Additional information 
 
If the PDF you attempt to print has ‘Do Not Allow Printing’ selected, then it will not print. 
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3.13. Run ARTS PDF Workshop 
 
Creates an ARTS PDF Workshop spreadsheet.  The information generated within the 
spreadsheet, is dependent on the options that the user selects. 
 

 
 

Figure 14. Run ARTS PDF Workshop 
 
Instructions on use 
 

1. Press the ‘Run ARTS PDF Workshop’ button (Figure 14). 
2. Click on ‘Browse’ button from the main menu to search and select a folder to run 

ARTS PDF Workshop on. 
3. Select the options you want from the ‘ARTS PDF Workshop GUI’ (Figure 15). 
4. Press ‘Start’ to initialize processing. 
 

 
 

Figure 15. ARTS PDF Workshop Main Dialog 

 
| CONTENTS |    Page 15 of 19   
   



  ARTS PDF Workshop User Guide 
  Appendix 
 

4. Appendix 
 
 

4.1. Spreadsheet Options 
 
When setting up a ARTS PDF Workshop spreadsheet, there is a range of options that can 
be selected. 
 
 
  
Title Displays the PDFs Title information. 
Subject Displays the PDFs Subject information. 
Author Displays the PDFs Author information. 
Keywords Displays the PDFs Keywords information. 
Page Count Displays the number of pages in the PDFs. 
Initial View Displays the way the PDFs will appear when opened in 

Acrobat. 
Filename Displays the file name of the PDFs 
Creator Displays the PDFs Creator information. 
Producer Displays the PDFs Producer information. 
Created Displays the date the PDFs were created. 
Optimized Displays whether or not the PDFs are optimized. 
File Size (Bytes) Displays the size of the PDFs (in bytes). 
Last Saved Displays the date when the PDFs were last saved. 
Security Settings Displays whether or not the PDFs contain open and / or 

security passwords, and Do Not Allow options.  Also allows the 
user to modify the security settings of multiple PDFs (if this 
option is not selected, security cannot be modified). 

Column Autofit Adjusts the column width to that of the data within it. 
Screen Updating Shows the information as it is written into the spreadsheet 

(turn off this option for faster run times). 
Hide Location Shows the complete file path of the PDF files in the worksheet.  

This is where the logs are inserted.  
Include Subfolders  Processes the PDF documents in the subfolders 
Save settings on 
close 

The settings that were last set would be remembered even 
when application is restarted. 
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5. Troubleshooting 
 
 

5.1. Frequently Asked Questions 
 
This section provides some answers to common questions and details on what to do if a 
problem is encountered concerning the following: 
 

• Document is already open 
• Missing toolbars 
• General 

 
Document is already open 
 
“I am getting an Error Message: "A document with the name 'PDFWorkshop.XLA' is 
already open..." 
 
To fix this, you need to completely remove and reinstall PDF Workshop:  

1. Uninstall  ARTS PDF Workshop.  
2. Open Excel.  
3. Select "View → Toolbars → Customize...".  
4. If "ARTS PDF Workshop" toolbar is still on the list, delete it. 
5. Close Excel, and reinstall PDF Workshop. 

 
Missing toolbars 
 
“The ARTS PDF Workshop toolbar has disappeared.  What can I do?” 
 
This is simply a matter of selecting it in Excel:  

1. Open Excel.  
2. Select "View → Toolbars".  
3. Select the "ARTS PDF Workshop" toolbar from the list. 

 
 
General 
 

“I am having a problem with ARTS PDF Workshop and it is not covered in this FAQ. What 
can I do?” 

 
• Visit our ARTS PDF Forum (http://forum.artspdf.com) to talk with ARTS PDF 

technical support and other ARTS PDF product users. Search the existing discussions 
and/or post your own questions. Each ARTS PDF product has it own dedicated 
discussion area. 

 
• Email techsupport@artspdf.com and one of our team will reply as soon as possible. 
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5.2. Forum 
 

Are you having a problem that you can’t find in the Frequently Asked Questions? Then 
perhaps you’ll find it on the ARTS PDF Forum.  Visit the ARTS PDF Forum on our website 
at http://forum.artspdf.com. 

 
 

5.3. Updates 
 

To ensure you are up-to-date with the most recently released bug fixes and new 
features; check that you have the latest version of ARTS PDF Workshop installed. 
To check if your version is the latest: 

1. Start Microsoft Excel. 
2. On the ARTS PDF Workshop toolbar click on Run ARTS PDF Workshop. 
3. Click on the About button. 
4. Choose Product Info and click Updates. 

 

5.4. Maintenance 
 
At times ARTS PDF will release updates that may include significant enhancements to 
the product.  It is recommended that you take up annual maintenance to be entitled to 
free upgrades (whether it be minor or major release versions) over a period of 12 
months from the initial purchase.  Annual Maintenance also entitles you to priority phone 
and email support.   
 
Annual maintenance can be purchased at the same time you buy the associated product 
from your ARTS PDF reseller.  If you wish to renew a subscription, or if you wish to 
purchase a subscription for a product you already own, please contact your reseller or 
ARTS PDF directly at info@artspdf.com
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5.5. Technical Support 
 

Before contacting us please read the complete Troubleshooting section as the answer to 
your problem may be found in the FAQs or on the ARTS PDF Forum.  To contact ARTS 
PDF Technical Support, please e-mail techsupport@artspdf.com and supply the 
information below to help us replicate the problem you are experiencing.   
 

a. The exact version of ARTS PDF Workshop you are using (this is located by 
running ARTS PDF Workshop, and then clicking Help > About Third-Party Plug-Ins 
> ARTS PDF Workshop > Product Info). Please also specify whether you are using 
a demo or full registered version.  

b. Whether or not you purchased Maintenance with ARTS PDF Workshop. If you did 
purchase Maintenance, please supply your ARTS PDF Workshop serial number.  

c. The exact version of the Operating System you are using.  
d. The amount of free disk space remaining.  
e. The CPU speed and amount of RAM for the system on which ARTS PDF Workshop 

is running (e.g. Pentium 233 MMX, 32MB RAM). 
f. Any other programs that are running at the time of the error (e.g. Outlook, 

Internet Explorer, etc).  
g. All error messages that were displayed when the error occurred.  
h. The exact series of steps that led to the error.   
i. Whether this error occurs on every PDF document or just a selected amount. If 

possible, please send us a sample of the file that caused the error. 
j. What program was used to create the PDF documents? E.g. Acrobat Distiller, 

Crystal Reports, Zeon PDF Driver, etc. 
 

 
 

Feedback If you have ideas and suggestions on how we could improve ARTS 
PDF Workshop, we would love to hear your thoughts. Please send 
them to info@artspdf.com
 

Legal Notes  
 

Acrobat and Exchange are registered trademarks of Adobe 
Systems Incorporated. ARTS PDF Workshop is Copyright © 2005 
ARTS PDF. 
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